Partial Outage: Customer Support Chat
Incident Report for TelQ
Resolved
This incident has been resolved.
Posted Sep 20, 2024 - 21:18 CEST
Investigating
We are currently experiencing an issue affecting the availability of our customer support chat for some users. Our team is actively working on a fix, and we expect full functionality to be restored by Monday, 23 September 2024, 12:00 PM. In the meantime, you can contact us via email at support@teltele.com. We apologize for any inconvenience this may cause and appreciate your understanding.
Posted Sep 20, 2024 - 18:56 CEST
This incident affected: Chat.